Article ID: 115416, created on Jan 15, 2013, last review on Jan 18, 2013

  • Applies to:
  • Business Automation

Symptoms


Provider revoked a privilege from Reseller Service Template in PBA and synchronized a reseller subscription based on the modified Service Template. The revoked privilege was removed from the list of available ones in properties of reseller staff members, however reseller still may use CP functionality provided by the revoked privilege. If reseller re-logs in PBA CP it does not solve the problem.

At the same time, if Provider add new privilege to the Reseller Service Template and synchronized reseller subscription based on the modified template, the new privilege will be correctly propagated to the reseller staff members. The problem takes place only in case Provider revokes a privilege from Reseller Service Template.

Cause


PBA incorrectly performs privileges update during reseller subscription synchronization.

Resolution


The problem will be fixed in the future updates to the product.

To solve the problem in the mean time restart PBA service:

PBA for Linux: # service pba restart
PBA for Windows: c:\> net stop ssm
c:\> net start pba

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