Article ID: 115150, created on Nov 16, 2012, last review on Aug 26, 2016

  • Applies to:
  • Operations Automation 6.0
  • Operations Automation 5.5
  • Operations Automation 5.4

Symptoms

A customer cannot assign Office 365 services to a user in OA Customer Control Panel due to various reasons complaining on the user's UPN (User Principal Name):

  1. Invalid input up_UserPrincipalName is invalid: Domain customer.com is not registered for use with Microsoft Online Services. Please add domain in Configuration of services before adding users of this domain.

  2. Invalid input up_UserPrincipalName is invalid: Domain customer.com is not verified yet. Please try again later.

Cause

The problem #1 is caused by the fact that a customer is trying to add Office 365 services to a Service User whose login name is created in the domain customer.com which is not delegated to Microsoft yet.

The problem #2 is caused by the fact that a customer is trying to add Office 365 services to a Service User whose login name is created in the domain customer.com which is not verified by Microsoft yet.

Office 365 services may be provided to Service Users which satisfy both conditions below:

  • Service User is created with login name containing domain which is delegated to Office 365 already
  • Service User is created with login name containing domain which is verified by Microsoft

Resolution

To solve the problem #1, delegate the domain customer.com to Office 365 in OA Customer CP at Microsoft Office 365 > Configuration > Domains.

To solve the problem #2:

  • Make sure that CNAME DNS records required by Microsoft domain verification process was added to the domain customer.com
  • Check if domain is verified in Microsoft Online Portal
  • Wait until domain is verified by OA

Refer to the Knowledgebase article #111517 [Office 365] Domain verification process for the detailed description of domain verification process in Office 365 and ways to troubleshoot and solve the problem.

Search Words

is not verified yet. Please try again later

Invalid value passed for setting 'up_UserPrincipalName'

office 365 provisioning

Service 'user' can not be provided for application instance: Invalid value passed for setting 'up_UserPrincipalName'

Please add domain in Configuration of services before adding users of this domain

error by updating: Error during OpenAPI call: Domain #4297 does not exist.

provisioning an account

caea8340e2d186a540518d08602aa065 5356b422f65bdad1c3e9edca5d74a1ae e12cea1d47a3125d335d68e6d4e15e07 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e ac82ce33439a9c1feec4ff4f2f638899 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0

Email subscription for changes to this article
Save as PDF