Article ID: 114839, created on Sep 25, 2012, last review on Aug 15, 2013

  • Applies to:
  • Operations Automation

Symptoms


NG Hosting provisioning fails with the error message below:
FrontPage extensions are not installed on Apache service
The problem also may appear in POA Customer CP when trying to uninstall FrontPage from the website management page, the error below is returned:
FrontPage uninstallation result
FrontPage not scheduled for uninstalling

Cause


FrontPage is not supported on NG Hosting. Actually POA will not allow to activate FrontPage on brand new subscription with NG Hosting, the error message 'FrontPage extensions are not installed on Apache service' will appear in the POA log.

The only known way how FrontPage support may be activated on NG Hosting subscription is migration from Legacy Linux Shared Hosting to NG Hosting. Migration tool will throw the error message: Fri Mar 23 12:13:58 2012: NOTICE: Check if subscriptions from host can be provisioned on web cluster/server
Fri Mar 23 12:13:58 2012: ERROR: Error trace: Traceback (most recent call last):
  File "/root/migrate/modules/uAction.py", line 99, in fn
    return fun(*args, **kwds)
  File "/root/migrate/migration/migutils.py", line 49, in tmpfunc
    func(*args, **kwargs)
  File "/root/migrate/migration/objects.py", line 353, in checkConfigPrerequisites
    raise PrerequisiteError("NG hosting doesn't support MS FrontPage, but subscription %s uses it. Remove MS FrontPage from subscription and try again." % sub.subID)
PrerequisiteError: NG hosting doesn't support MS FrontPage, but subscription 238 uses it. Remove MS FrontPage from subscription and try again.
Fri Mar 23 12:13:58 2012: ERROR: NG hosting doesn't support MS FrontPage, but subscription 238 uses it. Remove MS FrontPage from subscription and try again. while None

However, Provider may ignore the error message and continue migration, as a result subscription will be migrated to NG Hosting cluster and usage of FrontPage resource will not be reset to 0.

Resolution


The problem is going to be solved in POA 5.5. In the mean time contact Parallels Support Team to resolve the problem.

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