Article ID: 114548, created on Aug 10, 2012, last review on May 4, 2014

  • Applies to:
  • Business Automation

Symptoms

A provider created two similar Service Plans in PBA, and wants to allow customers to switch between the plans.

The provider goes to one of the Service Plan's properties, clicks on the Allowed Upgrades/Downgrades tab, and then clicks on the "Add New Allowed Upgrade/Downgrade" button. The desired Service Plan does not appear in the list of plans which may be configured as an upgrade/downgrade option.

Cause

Plans have different billing types, including post-paid and pre-paid. The billing type is controlled by the parameter Charge for Subscription in the Service Plan properties. The parameter may be set to one of the following values:

  • Before Subscription Period
  • Before Billing Period
  • After Billing Period

The two first options define a pre-paid plan, while the last one defines a post-paid plan. PBA does not allow you to switch from pre-paid plans to post-paid ones and vice versa, which is why plans with different billing types cannot be configured on the Allowed Upgrades/Downgrades tab. For details please refer to PBA documentation - Configuring Switch Parameters.

Resolution

Consider making both plans belong to the same billing type (pre- or post-paid).

Keep in mind that PBA does not allow you to change the billing type of a Service Plan if the plan already has subscriptions or is delegated to resellers.

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