Article ID: 114298, created on Jul 6, 2012, last review on May 11, 2014

  • Applies to:
  • Operations Automation

Symptoms


An APS package installation in POA Customer CP fails. The simiar output can be observed in the failed task properties:
Instance of application with id $ID and version '$VER' can not be provided:
Invalid value passed for setting '':
Value does not match regular expression: ^[0-9a-zA-Z_\-]*


Cause


Most likely the APS package vendor specified a regular expression to validate settings values for some fields and the user-defined values do not match the regular expression.

Resolution


  1. Open the APP-META.xml file of the APS Application in question with a text editor and search for regex string:
    <setting id="login" type="string" class="login" installation-only="true" regex="^[0-9a-zA-Z_\-]*">
    <name>User's login</name>
    </setting>
  2. Check the user-defined value in poa-debug.log:
    Jun 26 12:49:26 poa : INF [SYSTEM 1:28634:b27c5ba0 OpenAPI]: ==>>> Executing OpenAPI method 'pem.addAccount' with parameters: 
    [{ 
    'account_id' => 1234567, 
    'account_type' => 'C', 
    'address' => { 
    'address2' => '', 
    'city' => '', 
    'country' => 'ru', 
    'state' => '', 
    'street_name' => '', 
    'zipcode' => '', 
    }, 
    'auth' => { 
    'login' => 'user.name', 
    'password' => 'mypassword', 
    }, 
    'email' => 'someone@domain.tld', 
    'fax' => { 
    'area_code' => '', 
    'country_code' => '', 
    'ext_num' => '', 
    'phone_num' => '', 
    }, 
    'parent_account_id' => 1000001, 
    'person' => { 
    'company_name' => 'My company', 
    'first_name' => 'John', 
    'last_name' => 'Doe', 
    'middle_name' => '', 
    }, 
    'phone' => { 
    'area_code' => '', 
    'country_code' => '', 
    'ext_num' => '', 
    'phone_num' => '111', 
    }, 
    },]

    In this example user name contains the (.) symbol, which does not match the regexp ^[0-9a-zA-Z_\-]*.
     
  3. Contact APS Packager to correct the regex value to accept these values

NOTE: This issue is most likely to happen if the APS is automatically installed upon subscription creation, when the activation parameter Automatically install application during subscription provisioning is enabled for the application resource in the service template. In this case all the values are provided by PBA via OpenAPI and are not pre-validated in User Interface. As a workaround it is possible to disable automatic provisioning of the application to get user-defined values validated in Customer's Control Panel.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF