Article ID: 114031, created on May 31, 2012, last review on May 31, 2012


Some H-Sphere's perl modules do not work with Perl 5.10.1 on FreeBSD 7.4.
For example, the SpamAssassin module does not work:
$ /hsphere/shared/bin/spamd
Segmentation fault


To resolve the problem, you should either update the perl package to 5.12.4 on your server, or install the updated version of the hsphere-perl package which contains modules compatible with Perl 5.10.1.
To update the hsphere-perl package on your FreeBSD 7.4 i386 nodes, run the following commands on each node:
$ pkg_delete --force hsphere-perl*
$ pkg_add --force

For the FreeBSD 7.4 amd64 nodes, use the commands:
$ pkg_delete --force hsphere-perl*
$ pkg_add --force

2e39a5e5b1423cc126cf735bac076008 6311ae17c1ee52b36e68aaf4ad066387 f213b9fa8759d57bee5d547445806fe7

Email subscription for changes to this article
Save as PDF