Article ID: 114003, created on May 29, 2012, last review on May 11, 2014

  • Applies to:
  • Business Automation

Symptoms


Symantec and GeoTrust SSL Certificates fail to be processed. The issue occurs with periods of more than 4 years.

Cause


The following notice can be found in the Enom API official guide for version 7.4 (http://www.enom.com/APICommandCatalog/index.htm):

Changes that require code updates if you have implemented the functionality:

SSL Certificates: Symantec and GeoTrust are planning to change the maximum subscription period on all non-EV certificates to 5 years. Previously, certificates could be purchased in terms of up to 5-10 years. To honor the extra months given by Symantec and GeoTrust for early renewals, the eNom API will limit subscriptions to a maximum of 4 years. These changes will be released in June 2012.

The affected certificates and product types are as follows:
- Symantec Secure Site (180)
- Symantec Secure Site Pro (181)
- RapidSSL (23)
- GeoTrust QuickSSL (26)
- GeoTrust Quick SSL Premium (20)
- GeoTrust True BusinessID (21)
- GeoTrust True BusinessID Wildcard (27)


These changes become effective on May 30, 2012.

Resolution

Any Subscription Period with a duration of more than 4 years should be deleted from the appropriate Service Plan.
I. You may follow the following instructions to find all Subscription Periods that need to be deleted:
1. Go to the Parallels Business Automation (PBA) Application installation.
2. Go to the tools directory of PBA:
    - On Linux: /usr/local/bm/tools
    - On Windows: %PBA_ROOT%/ tools
3. Download the script ./getObsoletedPeriods.pl:
http://download.pa.parallels.com/pba/5.1/5.1.0-release/hotfixes/hf-114003-CERTGATE/getObsoletedPeriods.pl
4. Run the script:
    - On Linux: perl getObsoletedPeriods.pl
    - On Windows:
         cd ..
         perl\bin\perl.exe tools\getObsoletedPeriods.pl
5. The log file getObsoletedPeriods.log with a list of periods to be deleted will be created in the tools directory. The following info can be found there:
VendorAccount - account the Service Plan belongs to (Provider or Reseller)
PlanID - Service Plan ID
PeriodID - Subscription Period ID
Duration - Subscription Period Duration
CertName - Service Plan Certificate Product Type

II. Delete all Periods listed from the appropriate Service Plans. If you are not able to delete a Service Plan Period, mark it as disabled.
1. Log in to PBA Control Panel under the appropriate Vendor Account.
2. Go to Top > Product Director > Plan Manager > Service Plans.
3. Select the appropriate Service Plan.
4. Go to the Subscription Periods tab.
5. Check all Subscription Periods needed and click the "Delete" button. If some Subscription Periods cannot be deleted:
    - Select the Subscription Period.
    - Click the "Edit" button.
    - Uncheck the "Active" field.
    - Click the "Save" button.

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