Article ID: 113916, created on May 17, 2012, last review on May 5, 2014

  • Applies to:
  • Operations Automation 5.4

Symptoms


Customer cannot add phone number in POA CCP to their user with Hosted PBX service because either the list of locations or the list of available phone numbers is empty.

Cause


The possible reasons of problem are:
  • Provisioning Gateway Host cannot connect to the target BroadWorks system API.
  • Hosted PBX resource types are mis-configured.

Resolution


Make sure that Provisioning Gateway Host can access server configured in the 'BroadWorks API endpoint URL' parameter in the global settings of Hosted PBX application resource type:
  • Log into POA Provider Control Panel
  • Go to Top > Service Director > Application Manager > Applications > Hosted BroadWorks > Resource Types tab
  • Click on the resource type based on the resource class Application
  • Switch to the tab Activation Parameters > Global Settings
  • Find the BroadWorks API server in the parameter 'BroadWorks API endpoint URL'
  • Make sure that Provisioning Gateway Host can access BroadWorks API server using HTTPS port 443

Make sure that the list of 'Available Locations' is configured in the phone number resource type:
  • Log into POA Provider Control Panel
  • Go to Top > Service Director > Application Manager > Applications > Hosted BroadWorks > Resource Types tab
  • Click on the resource type based on the resource class Application Service, service = Phone Number
  • Switch to the tab Activation Parameters
  • Check if the parameter Available Locations is filled with correct values.

Available Locations - this setting defines the available locations and their phone number ranges. The following format should be used: LOCATION;+LOWER_BOUNDARY_OF_PHONE_RANGE;+UPPER_BOUNDARY_OF_PHONE_RANGE.
When a BroadWorks subscriber specifies the required location in POA CCP, the system searches for the phone numbers, which belong to the phone number range of the location. The found phone numbers are proposed to the BroadWorks subscriber.

Make sure that a pool contains phone numbers for the specified locations:
  • Log into POA Provider Control Panel
  • Go to Top > Service Director > Application Manager > Applications > Hosted BroadWorks > Resource Types tab
  • Click on the resource type based on the resource class Application Service, service = Phone Number
  • Switch to the tab Activation Parameters
  • Remember the value in the Pool Name parameter
  • Log into BroadWorks Control Panel using your Service Provider login and password
  • In the right panel, click Groups
  • Find the group with name taken from the properties of POA resource type (Pool Name), click it
  • In the left panel, click Resources
  • In the right panel, click Assign Numbers
  • Make sure that phone pool has free phone numbers (not assigned to users)

Refer to the BroadWorks Provider's Guide (section 'Creating 'Hosted PBX Phone Number' Resource Types') for details on proper Hosted PBX resources configuration.

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