Article ID: 113723, created on Apr 19, 2012, last review on Aug 12, 2014

  • Applies to:
  • Operations Automation

Symptoms

Customer's subscription with Microsoft Office 365 services expired and PBA-E disabled the subscription in POA. So, status of the subscription in PBA-E is Expired, service status of the subscription is Stopped, status of the subscription in POA is Disabled.

However, on the Microsoft Office 365 side the subscription was not disabled, it is still active.

Cause

During subscription disabling POA only disables users in Microsoft Office 365 (using the MOSI API request SetUser), the subscription itself is not being disabled.

Resolution

The problem is fixed in the latest update to the Office 365 APS application package - Microsoft Office 365 2.3.

Follow the steps below to solve the problem with expired subscriptions which are not disabled on the Microsoft Office 365 side:
  • Import new version of the APS package Office 365 in POA in Provider CP at Top > Service Director > Application Manager > Applications
  • Upgrade existing instances to the new version of package
  • For all disabled PA subscriptions with Office 365 services which are not really disabled on Microsoft side perform the following actions:
    • Enable subscription (using PBA-E or POA OpenAPI request pem.enableSubscription)
    • Disable subscription (using PBA-E or POA OpenAPI request pem.disableSubscription)

After currently disabled PA subscriptions are additionally activated/deactivated they will be deactivated on Microsoft side.

For more detalis refer to the Release Notes of the APS package Microsoft Office 365 2.3.

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