Article ID: 113285, created on Feb 7, 2012, last review on Aug 12, 2014

  • Applies to:
  • Operations Automation

Symptoms


Customer cannot add shared document to their SharePoint 2010 site, they are getting '403 Forbidden' error in browser.

On SharePoint 2010 frontend server the following entries are being logged in Event Viewer during an attempt to add document:

Log Name:      Application
Source:        Microsoft-SharePoint Products-SharePoint Foundation
Date:          17/01/2012 18:00:01
Event ID:      2138
Task Category: Health
Level:         Warning
Keywords:      
User:          HOSTING\SharePointAdmin
Computer:      WSSFE.hosting.local
Description:
The SharePoint Health Analyzer detected a condition requiring your attention.  The Security Token Service is not available.
The Security Token Service is not issuing tokens. The service could be malfunctioning or in a bad state.
Administrator should try to restart the Security Token Service on the boxes where it is not issuing tokens. If problem persists, further troubleshooting may be available in the KB article. For more information about this rule, see "http://go.microsoft.com/fwlink/?LinkID=160531".

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6FB7E0CD-52E7-47DD-997A-241563931FC2}" />
    <EventID>2138</EventID>
    <Version>14</Version>
    <Level>3</Level>
    <Task>8</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2012-01-17T17:00:01.202729600Z" />
    <EventRecordID>3476</EventRecordID>
    <Correlation ActivityID="{6189CC2E-AEFB-4CC7-A0A5-343A511CA8A9}" />
    <Execution ProcessID="1648" ThreadID="4912" />
    <Channel>Application</Channel>
    <Computer>WSSFE.hosting.local</Computer>
    <Security UserID="S-1-5-21-216329560-2360052097-1574991683-1173" />
  </System>
  <EventData>
    <Data Name="string0">The Security Token Service is not available.
The Security Token Service is not issuing tokens. The service could be malfunctioning or in a bad state.
Administrator should try to restart the Security Token Service on the boxes where it is not issuing tokens. If problem persists, further troubleshooting may be available in the KB article. For more information about this rule, see "http://go.microsoft.com/fwlink/?LinkID=160531".
</Data>
  </EventData>
</Event>

and

Log Name:      Application
Source:        Microsoft-SharePoint Products-SharePoint Foundation
Date:          17/01/2012 18:00:01
Event ID:      8306
Task Category: Claims Authentication
Level:         Error
Keywords:      
User:          HOSTING\SharePointAdmin
Computer:      WSSFE.hosting.local
Description:
An exception occurred when trying to issue security token: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>IIS 7.5 Detailed Error - 500.19 - Internal Server Error</title>
<style type="text/css">

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6FB7E0CD-52E7-47DD-997A-241563931FC2}" />
    <EventID>8306</EventID>
    <Version>14</Version>
    <Level>2</Level>
    <Task>47</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2012-01-17T17:00:01.202729600Z" />
    <EventRecordID>3475</EventRecordID>
    <Correlation ActivityID="{6189CC2E-AEFB-4CC7-A0A5-343A511CA8A9}" />
    <Execution ProcessID="1648" ThreadID="4912" />
    <Channel>Application</Channel>
    <Computer>WSSFE.hosting.local</Computer>
    <Security UserID="S-1-5-21-216329560-2360052097-1574991683-1173" />
  </System>
  <EventData>
    <Data Name="string0">The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>IIS 7.5 Detailed Error - 500.19 - Internal Server Error</title>
    </Data>
  </EventData>
</Event>
 

Cause


It is Microsoft SharePoint problem occurred because the SharePoint Search Query Logging thread reuses expired credentials.

Resolution


Check if all recommended updates listed in the Knowledgebase article #8770 'Supported SharePoint Versions' are installed on the SharePoint server in question and install them in case they are absent.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF