Article ID: 113275, created on Feb 6, 2012, last review on May 9, 2014

  • Applies to:
  • Odin Business Automation Standard 4.x

Symptoms

Customer cannot place order in PBA-S Online Store, on the last step they see error message:

--->8---
Dear customer, we can not accept your order at the moment due to technical reasons.
We would appreciate if you come back to us later and try to process again.
We apologize for the inconvenience.
---8<---

The frontend error log /var/log/httpd/hspc_frontend_error_log contains message about document with ID #513:

[Tue Jan 31 13:37:18 2012] [error] [client 91.204.25.4] Result: Array,(, [faultcode] => soap:Server, [faultstring] => Application error, [detail] => Array, (, [HSPC__Exc__Fatal] => Array, (, [msg] => no such document: '513', [calls_stack] => HSPC::Exc::Fatal::new(), line 148, Error::throw(), line 46, HSPC::Logger::sw_die(), line 2002, HSPC::MT::Billing::__pay_auto(), line 2071, HSPC::MT::Billing::pay_auto(), line 380, HSPC::API::Billing::_autopay_order(), line 294, HSPC::API::Billing::place_order(), line 2569, (eval)(), line 2557, (eval)(), line 2526, SOAP::Server::handle(), line 327, SOAP::Transport::HTTP::Server::handle(), line 621, SOAP::Transport::HTTP::Apache::handler(), line 762, HSPC::XMLAPI::handler(), line 0, (eval)(), line 0,, ),, ),,),, referer: http://store.provider.com/hspc/shopping_cart.php

However, there is no document with ID #513 in PBA-S Control Panel at

Top > Billing Director > Receivable > Documents

The problem is actual only for some hosting plan(s), other plans may be purchased without any problems in the Online Store.

Resolution steps

In many cases when you see error message in the Online Store PBA-S generates problem report which may be seen in the folder /var/log/hspc on the PBA-S Management Node, name of the problem report looks like /var/log/hspc/rep2012-02-06_03-42-39.

Perform the following steps to troubleshoot the problem:

  • Reproduce the problem in the Online Store
  • Check new problem report generated in PBA-S with current timestamp

Do use this command in PBA-S Management Node to check if problem report is generated during operating in the Online Store:

# tail -f /var/log/hspc/hspc.log | egrep 'FATAL|ERROR'

When error message is shown in the Online Store and problem report is generated the command above will show the report.

In the problem report one may find real reason of problem.

You cannot find document with ID #513 in PBA-S database because it was not created. During attempt to place order PBA-S creates order object temporarily and then destroys it because order cannot be placed.

Problem report generated during the attempt to place order contains the following entry:

[2012/02/06 03:42:39] [FATAL] [25990] [Error::throw] Limit for number of domains with DNS hosting exceeded

Cause

Hosting plan is configured incorrectly - limit on the resource Number of domains with DNS hosting provided (numdnshosting) is set to zero:

Included value              0 domain(s)
Maximum consumable value    0 domain(s)

Resolution

Set maximum consumable value for the resource Number of domains with DNS hosting provided (numdnshosting) in the problem hosting plan(s) to at least 1 or more.

Search Words

we can not accept your order at the moment due to technical reasons

cannot create order in store

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