Article ID: 113165, created on Jan 16, 2012, last review on Aug 17, 2015

  • Applies to:
  • Odin Business Automation Standard 4.5
  • Odin Business Automation Standard 4.2
  • Odin Business Automation Standard 4.1

Symptoms

It is not possible to access the Provider's Control Panel. After a successful login, the following message is displayed:

Unfortunately, the application you are trying to access is unavailable.
Common Reasons: 

  * Application has run out of Parallels Business Automation - Standard licenses.
  * Parallels Business Automation - Standard license for the application is expired, invalid, or missing.
  * Server is temporarily overloaded.

Cause

OBAS license issues. To find out what exactly is causing the issue please check the status of the installed license under Top > Configuration Director > License Manager > Parallels Business Automation - Standard Licenses

The license has expired

If there are Inactive statuses for Concurrently Logged Staff Members, Reseller Accounts and Customer Accounts, and in the Expires column next to them are dates in the past, it means that the license has expired and was not automatically renewed.

Resolution

Please either obtain a renewed license from your sales representative or open a ticket with Odin Technical Support to get a trial license. Once a new license is received, upload it using the following instructions:

  • Back up the current license:

        # cp /etc/hspc/licenses/hspclicense /etc/hspc/licenses/hspclicense.sav
    
  • Put the new license into the /etc/hspc/licenses/hspclicense file.
  • Restart the hspcd service:

        /etc/init.d/hspcd restart
    

Maximum allowed users are logged in

Check the Unused value for Concurrently Logged Staff Members. If it equals 0, it means that maximum amount of users with the permission to log in to PCC are now logged in.

Resolution

Please wait until someone logs off thus releasing a session or restart the hspcd service.

User gets automatically logged out of PCC after 20 minutes of inactivity. There us a countdown TTL counter that resets to hardcoded value of 1200 seconds on each user activity. When the counter reaches 0, the user is logged out.

Information on the users currenly logged in and their TTL is available on the Usage Information screen. To get there, click on Concurrently Logged Staff Members link under Top > Configuration Director > License Manager > Parallels Business Automation - Standard Licenses and switch to the Usage Information tab.

License limits were exceeded

There is more In Use than Total for Reseller Accounts or Customer Accounts. The following error in /var/log/hspc/hspc.log confirms that:

License Violation: There is no free license count for CP license 

Resolution

  1. Please purchase a new license that accounts for the limits increased. Please note that Reseller Accounts is the number of reseller accounts in the Active status, while Customer Accounts is the number of Active customer accounts having at least one Active subscription. The resellers' customer accounts are not counted for this position.

  2. Request a trial license with limits overlapping your current usage, install it, remove unnecessary resellers and customers and reinstall your original license.

Search Words

Parallels Business Automation - Standard license for the application is expired, invalid, or missing

PBAS unable to load at all

Server is temporarily overloaded

license

API-RPC request 'service-node/reread-info' has been failed

License Violation: There is no free license count for CP license

Application has run out of Parallels Business Automation - Standard licenses.

service-node reread-info

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