Article ID: 112263, created on Sep 13, 2011, last review on Aug 12, 2014

  • Applies to:
  • Operations Automation 5.2
  • Operations Automation 5.1
  • Operations Automation 5.0

Symptoms


POA background tasks related to BlackBerry services provisioning fail with error:Provisioning request failed. Error in 'BESProvider.addUser'
Error setting up authentication: Unable to connect to the remote server
Unable to connect to the remote server


When tried to execute BES Administration tools directly from the MPS server it fails with the error like below: > "C:\Program Files\swsoft\PEM\MPF Providers\BES5X\BESUserAdminClient.exe" -find -u test@example.com -n https://bes01 -username pem_admin -password Pa$$w0Rd
BlackBerry(R) Enterprise Server User Administration Tool Version 5.0.3.3
Copyright (c) Research In Motion, Ltd. 2009-2010. All rights reserved.
Log files being written to C:\Documents and Settings\pem_admin\Application Data\Research In Motion\BlackBerry User Administration Tool Client\Logs.
(08/29 08:56:16) Error setting up authentication: Unable to connect to the remote server
(08/29 08:56:16) Unable to connect to the remote server
(08/29 08:56:16) Command Results:


Cause


Both version 4.x and 5.x of the BlackBerry User Administration Tool are installed on the MPS server while BlackBerry Enterprise Server version 4.x is used in the system. POA is not able to select version 4.x of the BlackBerry User Administration Tool correctly and fails to communicate with BlackBerry Enterprise Server.

Resolution


1. Log into MPS node.

2. Add the following configuration parameter to the <MPF Providers Root>\BESProvider.dll.config file:<add key="disableBES5Tools" value="true" />

3. Restart the ProvEngine COM+ application following instructions in the KB article https://kb.odin.com/1851.

4. Repeat steps 1-3 on each MPS node if you have MPS cluster.

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